5710 C++ Programming Manual: D:/5710/Cpp Directory Reference

5710 C++ Programming Manual
Cpp Directory Reference

Files

file JY5710.h
@SectionBegin JY5710 FileHead
Generated by doxygen 1.9.1


5710 C++ Programming Manual: D:/5710/Cpp/JY5710.h File Reference

Typedefs | Enumerations | Functions
JY5710.h File Reference

@SectionBegin JY5710 FileHead More...

Typedefs

typedef void * JY5710_DeviceHandle
@SectionEnd JY5710_Device FileHead More...

Enumerations

enum | JY5710_ReferenceClock { JY5710_Internal = 0x0 , JY5710_PXIe_Clk100 = 0x1 }
enum | JY5710_AO_UpdateMode { JY5710_AO_Finite = 0x0 , JY5710_AO_ContinuousWrapping = 0x1 , JY5710_AO_ContinuousNoWrapping = 0x2 , JY5710_AO_Single = 0x3 }
enum | JY5710_TriggerMode { JY5710_StartTrigger = 0x0 , JY5710_ReferenceTrigger = 0x1 }
enum | JY5710_AO_TriggerType { JY5710_AO_Immediately = 0x0 , JY5710_AO_Digital = 0x1 , JY5710_AO_Soft = 0x3 }
enum | JY5710_DigitalTriggerEdge { JY5710_Rising = 0x0 , JY5710_Falling = 0x1 }
enum JY5710_DigitalTriggerSource {
JY5710_PFI0 = 0x1 , JY5710_PFI1 = 0x2 , JY5710_PFI2 = 0x3 , JY5710_PXI_Trig0 = 8 ,
JY5710_PXI_Trig1 = 9 , JY5710_PXI_Trig2 = 10 , JY5710_PXI_Trig3 = 11 , JY5710_PXI_Trig4 = 12 ,
JY5710_PXI_Trig5 = 13 , JY5710_PXI_Trig6 = 14 , JY5710_PXI_Trig7 = 15
}
enum | JY5710_ClockSource { JY5710_InternalClock = 0x0 , JY5710_ExternalClock = 0x1 }
enum JY5710_ExternalClockTerminal {
JY5710_PFI_0_IN = 1 , JY5710_PFI_1_IN = 2 , JY5710_PFI_2_IN = 3 , JY5710_PXI_Trig0_IN = 8 ,
JY5710_PXI_Trig1_IN = 9 , JY5710_PXI_Trig2_IN = 10 , JY5710_PXI_Trig3_IN = 11 , JY5710_PXI_Trig4_IN = 12 ,
JY5710_PXI_Trig5_IN = 13 , JY5710_PXI_Trig6_IN = 14 , JY5710_PXI_Trig7_IN = 15
}
enum | JY5710_Signal_Source { JY5710_AO_StartTrig = 18 , JY5710_AO_SampleClock = 19 }
enum JY5710_Signal_Destination {
JY5710_PFI0_OUT = 1 , JY5710_PFI1_OUT = 2 , JY5710_PFI2_OUT = 3 , JY5710_PXITrig0_OUT = 8 ,
JY5710_PXITrig1_OUT = 9 , JY5710_PXITrig2_OUT = 10 , JY5710_PXITrig3_OUT = 11 , JY5710_PXITrig4_OUT = 12 ,
JY5710_PXITrig5_OUT = 13 , JY5710_PXITrig6_OUT = 14 , JY5710_PXITrig7_OUT = 15
}

Functions

JY5710API int | JY5710_Open (int slotNumber, JY5710_DeviceHandle *hDevice)
Open the 5710 series boards using the slot number or the board serial number. More...
JY5710API int | JY5710_OpenByName (const char *cardName, JY5710_DeviceHandle *hDevice)
Open this 5710 series boards using the board alias name which is set by JYTEK utility JYDM. More...
JY5710API int | JY5710_GetDeviceID (JY5710_DeviceHandle hDevice, int *deviceID)
Obtain the board ID. More...
JY5710API int | JY5710_SetDeviceStatusLed (JY5710_DeviceHandle hDevice, bool enable, unsigned int frequency)
Control Front Panel Status Led More...
JY5710API int | JY5710_GetDeviceSerialNumber (JY5710_DeviceHandle hDevice, char *serialNumber, int length)
Obtain the device serialNumber More...
JY5710API int | JY5710_Close (JY5710_DeviceHandle hDevice)
Close this 5710 board. More...
JY5710API int | JY5710_SignalRouting (JY5710_DeviceHandle hDevice, JY5710_Signal_Source source, JY5710_Signal_Destination destination)
Route a singal from source to destination. More...
JY5710API int | JY5710_DisconnectSignalRouting (JY5710_DeviceHandle hDevice, JY5710_Signal_Destination destination)
Disconnect an established routing. More...
JY5710API int | JY5710_SetDeviceReferenceClock (JY5710_DeviceHandle hDevice, JY5710_ReferenceClock clkSource)
Set ReferenceClock for the device.There are two ReferenceClock, 25MHz from this device or 100MHz from the PXIe chassis. More...
JY5710API int | JY5710_GetDeviceFPGATemperature (JY5710_DeviceHandle hDevice, double *temperature)
Get FPGA temperature reading of the device in Celsius degree. More...
JY5710API int | JY5710_DI_AddLines (JY5710_DeviceHandle hDevice, unsigned int *line, unsigned int lineCount)
Enabled DI channels. More...
JY5710API int | JY5710_DI_ReadSinglePoint (JY5710_DeviceHandle hDevice, bool *readValues, int lineID)
DI read single data from a single line by lineID defined.if the lineID == -1,read all line data. More...
JY5710API int | JY5710_DI_ReadSinglePoint_U8 (JY5710_DeviceHandle hDevice, unsigned char *readValue)
DI read single data for all line.the data type is unsigned char, the bit 0 to 2 defined line 0 to 2 status. More...
JY5710API int | JY5710_DI_Start (JY5710_DeviceHandle hDevice)
Start DI acquisition. More...
JY5710API int | JY5710_DI_Stop (JY5710_DeviceHandle hDevice)
Stop DI acquisition. More...
JY5710API int | JY5710_DO_AddLines (JY5710_DeviceHandle hDevice, unsigned int *line, unsigned int lineCount)
Enabled DO channels More...
JY5710API int | JY5710_DO_WriteSinglePoint (JY5710_DeviceHandle hDevice, bool *writeValues, int lineID)
DO write single data to a single line by lineID defined.if the lineID == -1,write all line data. More...
JY5710API int | JY5710_DO_WriteSinglePoint_U8 (JY5710_DeviceHandle hDevice, unsigned char *writeValue)
DO write single data to all line.the data type is unsigned char, the bit 0 to 2 defined line 0 to 2 status. More...
JY5710API int | JY5710_DO_Start (JY5710_DeviceHandle hDevice)
Start digital signal output. More...
JY5710API int | JY5710_DO_Stop (JY5710_DeviceHandle hDevice)
Stop digital signal output. More...
JY5710API int | JY5710_AO_EnableChannel (JY5710_DeviceHandle hDevice, unsigned int channelCount, unsigned char *channels, double *lowRegion, double *highRegion)
Enables AO channels. More...
JY5710API int | JY5710_AO_SetUpdateRate (JY5710_DeviceHandle hDevice, double updateRate, double *actualUpdateRate)
Set AO update rate for each channel. More...
JY5710API int | JY5710_AO_SetMode (JY5710_DeviceHandle hDevice, JY5710_AO_UpdateMode mode)
Set digital signal output mode, the mode defined by enum JY5710_AO_UpdateMode. More...
JY5710API int | JY5710_AO_SetSamplesToUpdate (JY5710_DeviceHandle hDevice, unsigned int sampleToUpdate)
Set digital signal output samples for each channel in the finite mode.The sample range is from 1 to 256M / channelCount. More...
JY5710API int | JY5710_AO_Start (JY5710_DeviceHandle hDevice)
Start digital signal output. More...
JY5710API int | JY5710_AO_WriteRawData (JY5710_DeviceHandle hDevice, short *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualWriteLength)
AO write raw data.The data is interleaved in the buffer in channel order for multi-channel. More...
JY5710API int | JY5710_AO_WriteData (JY5710_DeviceHandle hDevice, double *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualWriteLength)
AO writes data.The data is interleaved in the buffer the order defined by JY5710_AO_EnableChannel. More...
JY5710API int | JY5710_AO_Stop (JY5710_DeviceHandle hDevice)
Stop digital signal output. More...
JY5710API int | JY5710_AO_SetSampleClock (JY5710_DeviceHandle hDevice, JY5710_ClockSource clockSource, JY5710_ExternalClockTerminal terminal, double expectedRate)
Set AO sampling clock. More...
JY5710API int | JY5710_AO_WriteRawSinglePoint (JY5710_DeviceHandle hDevice, unsigned short *writeValues, int channelID)
AO write single point data to the defined channel by channelID, if channelID == -1, write all enable channel. More...
JY5710API int | JY5710_AO_WriteSinglePoint (JY5710_DeviceHandle hDevice, double *writeValues, int channelID)
AO write single point data to the defined channel by channelID, if channelID == -1, write all enable channel. More...
JY5710API int | JY5710_AO_SetStartTriggerType (JY5710_DeviceHandle hDevice, JY5710_AO_TriggerType triggerTyp)
Set AO start trigger type,the triggerType is defined by enum JY5710_AO_TriggerType. More...
JY5710API int | JY5710_AO_SetDigitalStartTrigger (JY5710_DeviceHandle hDevice, JY5710_DigitalTriggerSource triggerSource, JY5710_DigitalTriggerEdge triggerEdge)
Set AO digital start trigger,the triggerSource is defined by enum JY5710_DigitalTriggerSource, the triggerEdge is defined by enum JY5710_DigitalTriggerEdge. More...
JY5710API int | JY5710_AO_WaitUntilDone (JY5710_DeviceHandle hDevice, bool *done, int timeOut)
Check finite analog signal output is complete. More...
JY5710API int | JY5710_AO_CheckBufferStatus (JY5710_DeviceHandle hDevice, unsigned long *availableSamples, bool *overrun)
Check AO device buffer status.This API is intended to be compatible with older version drivers. More...
JY5710API int | JY5710_AO_CheckBufferStatusEx (JY5710_DeviceHandle hDevice, unsigned long *availableSamples, unsigned long long *transferedSamples, bool *overrun)
Check AO device buffer status. More...
JY5710API int | JY5710_AO_SendSoftTrigger (JY5710_DeviceHandle hDevice)
Send the software trigger signal. More...
JY5710API int | JY5710_DisableAOCalibration (JY5710_DeviceHandle hDevice, bool DisableCalibration)
Disable AO calibration coefficient, default enable calibration coefficient More...

Detailed Description

@SectionBegin JY5710 FileHead

COPYRIGHT NOTICE
Copyright (c) 2018-2021, JYTEK
All rights reserved.
Author
JYTEK
Version
1.0.1
Date
2021-6-22

This header file defines C/C++ API and enums used in the JY5710 driver.

Revision Notes:

Typedef Documentation

◆ JY5710_DeviceHandle

typedef void* JY5710_DeviceHandle

@SectionEnd JY5710_Device FileHead

Windows Linux

Enumeration Type Documentation

◆ JY5710_AO_TriggerType

enum JY5710_AO_TriggerType
Enumerator
JY5710_AO_Immediately | AO Immediately trigger.
JY5710_AO_Digital | AO Digital trigger.
JY5710_AO_Soft | AO Soft trigger.

◆ JY5710_AO_UpdateMode

enum JY5710_AO_UpdateMode
Enumerator
JY5710_AO_Finite | AO Finite mode.
JY5710_AO_ContinuousWrapping | AO ContinuousWrapping mode.
JY5710_AO_ContinuousNoWrapping | AO ContinuousNoWrapping mode.
JY5710_AO_Single | AO Single mode.

◆ JY5710_ClockSource

enum JY5710_ClockSource
Enumerator
JY5710_InternalClock | Internal Clock Source.
JY5710_ExternalClock | External Clock Source.

◆ JY5710_DigitalTriggerEdge

enum JY5710_DigitalTriggerEdge
Enumerator
JY5710_Rising | Rsing edge for digital trigger.
JY5710_Falling | Falling edge for digital trigger.

◆ JY5710_DigitalTriggerSource

enum JY5710_DigitalTriggerSource
Enumerator
JY5710_PFI0 | PFI_0 as the digital trigger source.
JY5710_PFI1 | PFI_1 as the digital trigger source.
JY5710_PFI2 | PFI_2 as the digital trigger source.
JY5710_PXI_Trig0 | PXI_Trig0 as the digital trigger source.
JY5710_PXI_Trig1 | PXI_Trig1 as the digital trigger source.
JY5710_PXI_Trig2 | PXI_Trig2 as the digital trigger source.
JY5710_PXI_Trig3 | PXI_Trig3 as the digital trigger source.
JY5710_PXI_Trig4 | PXI_Trig4 as the digital trigger source.
JY5710_PXI_Trig5 | PXI_Trig5 as the digital trigger source.
JY5710_PXI_Trig6 | PXI_Trig6 as the digital trigger source.
JY5710_PXI_Trig7 | PXI_Trig7 as the digital trigger source.

◆ JY5710_ExternalClockTerminal

enum JY5710_ExternalClockTerminal
Enumerator
JY5710_PFI_0_IN | PFI_0 as the external sample clock.
JY5710_PFI_1_IN | PFI_0 as the external sample clock.
JY5710_PFI_2_IN | PFI_0 as the external sample clock.
JY5710_PXI_Trig0_IN | PXI_Trig0 as external sample clock.
JY5710_PXI_Trig1_IN | PXI_Trig1 as external sample clock.
JY5710_PXI_Trig2_IN | PXI_Trig2 as external sample clock.
JY5710_PXI_Trig3_IN | PXI_Trig3 as external sample clock.
JY5710_PXI_Trig4_IN | PXI_Trig4 as external sample clock.
JY5710_PXI_Trig5_IN | PXI_Trig5 as external sample clock.
JY5710_PXI_Trig6_IN | PXI_Trig6 as external sample clock.
JY5710_PXI_Trig7_IN | PXI_Trig7 as external sample clock.

◆ JY5710_ReferenceClock

enum JY5710_ReferenceClock
Enumerator
JY5710_Internal | The onboard 25 MHz JY5710_ReferenceClock.
JY5710_PXIe_Clk100 | The PXIe chassis 100MHz JY5710_ReferenceClock, only for PXIe module.

◆ JY5710_Signal_Destination

enum JY5710_Signal_Destination
Enumerator
JY5710_PFI0_OUT | PFI0 as the signal desition to rout.
JY5710_PFI1_OUT | PFI1 as the signal desition to rout.
JY5710_PFI2_OUT | PFI2 as the signal desition to rout.
JY5710_PXITrig0_OUT | PXITrig0 as the signal desition to rout.
JY5710_PXITrig1_OUT | PXITrig1 as the signal desition to rout.
JY5710_PXITrig2_OUT | PXITrig2 as the signal desition to rout.
JY5710_PXITrig3_OUT | PXITrig3 as the signal desition to rout.
JY5710_PXITrig4_OUT | PXITrig4 as the signal desition to rout.
JY5710_PXITrig5_OUT | PXITrig5 as the signal desition to rout.
JY5710_PXITrig6_OUT | PXITrig6 as the signal desition to rout.
JY5710_PXITrig7_OUT | PXITrig7 as the signal desition to rout.

◆ JY5710_Signal_Source

enum JY5710_Signal_Source
Enumerator
JY5710_AO_StartTrig | AO_StartTrig as the source signal to rout.
JY5710_AO_SampleClock | AO_SampleClock as the source signal to rout.

◆ JY5710_TriggerMode

enum JY5710_TriggerMode
Enumerator
JY5710_StartTrigger | Start trigger mode.
JY5710_ReferenceTrigger | Reference trigger mode.

Function Documentation

◆ JY5710_AO_CheckBufferStatus()

JY5710API int JY5710_AO_CheckBufferStatus | ( | JY5710_DeviceHandle | hDevice,
 |  | unsigned long * | availableSamples,
 |  | bool * | overrun
 | ) |  |

Check AO device buffer status.This API is intended to be compatible with older version drivers.

It is recommended to use API JY5710_AO_CheckBufferStatusEx.

Parameters
hDevice | device handle
avaliableSamples | number of AO points per channel user can write
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5710_AO_CheckBufferStatusEx()

JY5710API int JY5710_AO_CheckBufferStatusEx | ( | JY5710_DeviceHandle | hDevice,
 |  | unsigned long * | availableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun
 | ) |  |

Check AO device buffer status.

Parameters
hDevice | device handle
avaliableSamples | number of AO points per channel user can write
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5710_AO_EnableChannel()

JY5710API int JY5710_AO_EnableChannel | ( | JY5710_DeviceHandle | hDevice,
 |  | unsigned int | channelCount,
 |  | unsigned char * | channels,
 |  | double * | lowRegion,
 |  | double * | highRegion
 | ) |  |

Enables AO channels.

Parameters
hDevice | device handle
channelCount | number of channels to be enabled
channels | array[channelCount] containing channelIDs
lowRegion | array[channelCount] of lower limit numbers for each channel,typically in volts.
highRegion | array[channelCount] of higher limit numbers for each channel, typcially in volts.
Returns
0 if success or other error code

◆ JY5710_AO_SendSoftTrigger()

JY5710API int JY5710_AO_SendSoftTrigger ( JY5710_DeviceHandle hDevice )

Send the software trigger signal.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5710_AO_SetDigitalStartTrigger()

JY5710API int JY5710_AO_SetDigitalStartTrigger | ( | JY5710_DeviceHandle | hDevice,
 |  | JY5710_DigitalTriggerSource | triggerSource,
 |  | JY5710_DigitalTriggerEdge | triggerEdge
 | ) |  |

Set AO digital start trigger,the triggerSource is defined by enum JY5710_DigitalTriggerSource, the triggerEdge is defined by enum JY5710_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AO digital start trigger source
triggerEdge | AO digital start trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY5710_AO_SetMode()

JY5710API int JY5710_AO_SetMode | ( | JY5710_DeviceHandle | hDevice,
 |  | JY5710_AO_UpdateMode | mode
 | ) |  |

Set digital signal output mode, the mode defined by enum JY5710_AO_UpdateMode.

Parameters
hDevice | device handle
mode | digital signal output mode.Options: Single,Finite,ContinuousWrapping,ContinuousNoWrapping
Returns
0 if success or other error code

◆ JY5710_AO_SetSampleClock()

JY5710API int JY5710_AO_SetSampleClock | ( | JY5710_DeviceHandle | hDevice,
 |  | JY5710_ClockSource | clockSource,
 |  | JY5710_ExternalClockTerminal | terminal,
 |  | double | expectedRate
 | ) |  |

Set AO sampling clock.

the source of the sampling clock defined by enum JY5710_ClockSource. If the clock source is external, need to configure external clock terminal and external clock frequency.

Parameters
hDevice | device handle
clockSource | AO sampling clock source
terminal | external clock terminal,defined by enum JY5710_ExternalClockTerminal
expectedRate | external clock frequency
Returns
0 if success or other error code

◆ JY5710_AO_SetSamplesToUpdate()

JY5710API int JY5710_AO_SetSamplesToUpdate | ( | JY5710_DeviceHandle | hDevice,
 |  | unsigned int | sampleToUpdate
 | ) |  |

Set digital signal output samples for each channel in the finite mode.The sample range is from 1 to 256M / channelCount.

Parameters
hDevice | device handle
sampleToUpdate | number of digital signal output samples per channel. Data range:1 to 256M / channelCount samples.
Returns
0 if success or other error code

◆ JY5710_AO_SetStartTriggerType()

JY5710API int JY5710_AO_SetStartTriggerType | ( | JY5710_DeviceHandle | hDevice,
 |  | JY5710_AO_TriggerType | triggerTyp
 | ) |  |

Set AO start trigger type,the triggerType is defined by enum JY5710_AO_TriggerType.

Parameters
hDevice | device handle
triggerType | AO start trigger type. Options: immediate trigger, software trigger, digital trigger .
Returns
0 if success or other error code

◆ JY5710_AO_SetUpdateRate()

JY5710API int JY5710_AO_SetUpdateRate | ( | JY5710_DeviceHandle | hDevice,
 |  | double | updateRate,
 |  | double * | actualUpdateRate
 | ) |  |

Set AO update rate for each channel.

Parameters
hDevice | device handle
updateRate | AO update rate to be set per channel
actualUpdateRate | AO update rate actually set. The actual update rate set by this device,which may be different from the desired updata rate.
Returns
0 if success or other error code

◆ JY5710_AO_Start()

JY5710API int JY5710_AO_Start ( JY5710_DeviceHandle hDevice )

Start digital signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5710_AO_Stop()

JY5710API int JY5710_AO_Stop ( JY5710_DeviceHandle hDevice )

Stop digital signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5710_AO_WaitUntilDone()

JY5710API int JY5710_AO_WaitUntilDone | ( | JY5710_DeviceHandle | hDevice,
 |  | bool * | done,
 |  | int | timeOut
 | ) |  |

Check finite analog signal output is complete.

Parameters
hDevice | device handle
done | true if completed, false if not yet completed.
timeOut | timeout time in microsecond
Returns
0 if success or other error code

◆ JY5710_AO_WriteData()

JY5710API int JY5710_AO_WriteData | ( | JY5710_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualWriteLength
 | ) |  |

AO writes data.The data is interleaved in the buffer the order defined by JY5710_AO_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer of output data.The buffer size must be greater than or equal to dataLength*number of enabled channels.
dataLength | total number of output data for all channels
timeOut | timeout time in microsecond
actualWriteLength | the number of points per channel actually write
Returns
0 if success or other error code

◆ JY5710_AO_WriteRawData()

JY5710API int JY5710_AO_WriteRawData | ( | JY5710_DeviceHandle | hDevice,
 |  | short * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualWriteLength
 | ) |  |

AO write raw data.The data is interleaved in the buffer in channel order for multi-channel.

Parameters
hDevice | device handle
dataBuffer | user buffer, the buffer size must be greater than or equal to dataLength*number of enabled channels.
dataLength | total number of output data for all channels
timeOut | timeout time in microsecond
actualWriteLength | the number of points per channel actually write
Returns
0 if success or other error code

◆ JY5710_AO_WriteRawSinglePoint()

JY5710API int JY5710_AO_WriteRawSinglePoint | ( | JY5710_DeviceHandle | hDevice,
 |  | unsigned short * | writeValues,
 |  | int | channelID
 | ) |  |

AO write single point data to the defined channel by channelID, if channelID == -1, write all enable channel.

Parameters
hDevice | device handle
writeValues | write value for each enable channel,when channelID == -1, the writeValue length must equal to channelCount
channelID | defined channelID
Returns
0 if success or other error code

◆ JY5710_AO_WriteSinglePoint()

JY5710API int JY5710_AO_WriteSinglePoint | ( | JY5710_DeviceHandle | hDevice,
 |  | double * | writeValues,
 |  | int | channelID
 | ) |  |

AO write single point data to the defined channel by channelID, if channelID == -1, write all enable channel.

Parameters
hDevice | device handle
writeValues | write value for each enable channel,when channelID == -1 the writeValue length must equal to channelCount
channelID | defined channel, if channelID == -1, write all enable channel
Returns
0 if success or other error code

◆ JY5710_Close()

JY5710API int JY5710_Close ( JY5710_DeviceHandle hDevice )

Close this 5710 board.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5710_DI_AddLines()

JY5710API int JY5710_DI_AddLines | ( | JY5710_DeviceHandle | hDevice,
 |  | unsigned int * | line,
 |  | unsigned int | lineCount
 | ) |  |

Enabled DI channels.

Parameters
hDevice | device handle
line | array[lineCount] containing lineIDs
lineCount | number of lines to be enabled
Returns
0 if success or other error code

◆ JY5710_DI_ReadSinglePoint()

JY5710API int JY5710_DI_ReadSinglePoint | ( | JY5710_DeviceHandle | hDevice,
 |  | bool * | readValues,
 |  | int | lineID
 | ) |  |

DI read single data from a single line by lineID defined.if the lineID == -1,read all line data.

Parameters
hDevice | device handle
readValues | read the specified line value. when the lineID is -1, read all enabled lines values,the readValues Length must equal to lineCount(In function JY5710_DI_AddLines defined), and the values store in the add order of lines.
lineID | line number
Returns
0 if success or other error code

◆ JY5710_DI_ReadSinglePoint_U8()

JY5710API int JY5710_DI_ReadSinglePoint_U8 | ( | JY5710_DeviceHandle | hDevice,
 |  | unsigned char * | readValue
 | ) |  |

DI read single data for all line.the data type is unsigned char, the bit 0 to 2 defined line 0 to 2 status.

Parameters
hDevice | device handle
readValue | read all line value
Returns
0 if success or other error code

◆ JY5710_DI_Start()

JY5710API int JY5710_DI_Start ( JY5710_DeviceHandle hDevice )

Start DI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5710_DI_Stop()

JY5710API int JY5710_DI_Stop ( JY5710_DeviceHandle hDevice )

Stop DI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5710_DisableAOCalibration()

JY5710API int JY5710_DisableAOCalibration | ( | JY5710_DeviceHandle | hDevice,
 |  | bool | DisableCalibration
 | ) |  |

Disable AO calibration coefficient, default enable calibration coefficient

Parameters
hDevice | device handle
DisableCalibration | true if disabled, false if not disabled.
Returns
0 if success or other error code

◆ JY5710_DisconnectSignalRouting()

JY5710API int JY5710_DisconnectSignalRouting | ( | JY5710_DeviceHandle | hDevice,
 |  | JY5710_Signal_Destination | destination
 | ) |  |

Disconnect an established routing.

Parameters
hDevice | device handle
destination | destination of the signal defined by enum JY5710_Signal_Destination
Returns
0 if success or other error code

◆ JY5710_DO_AddLines()

JY5710API int JY5710_DO_AddLines | ( | JY5710_DeviceHandle | hDevice,
 |  | unsigned int * | line,
 |  | unsigned int | lineCount
 | ) |  |

Enabled DO channels

Parameters
hDevice | device handle
line | array[lineCount] containing lineIDs
lineCount | number of lines to be enabled
Returns
0 if success or other error code

◆ JY5710_DO_Start()

JY5710API int JY5710_DO_Start ( JY5710_DeviceHandle hDevice )

Start digital signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5710_DO_Stop()

JY5710API int JY5710_DO_Stop ( JY5710_DeviceHandle hDevice )

Stop digital signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5710_DO_WriteSinglePoint()

JY5710API int JY5710_DO_WriteSinglePoint | ( | JY5710_DeviceHandle | hDevice,
 |  | bool * | writeValues,
 |  | int | lineID
 | ) |  |

DO write single data to a single line by lineID defined.if the lineID == -1,write all line data.

Parameters
hDevice | device handle
writeValues | write the specified line value. when the lineID is -1, write all enabled lines values,the writeValues Length must equal to lineCount(In function JY5710_DO_AddLines defined), and the values store in the add order of lines.
lineID | line number
Returns
0 if success or other error code

◆ JY5710_DO_WriteSinglePoint_U8()

JY5710API int JY5710_DO_WriteSinglePoint_U8 | ( | JY5710_DeviceHandle | hDevice,
 |  | unsigned char * | writeValue
 | ) |  |

DO write single data to all line.the data type is unsigned char, the bit 0 to 2 defined line 0 to 2 status.

Parameters
hDevice | device handle
writeValues | write all line value..
Returns
0 if success or other error code

◆ JY5710_GetDeviceFPGATemperature()

JY5710API int JY5710_GetDeviceFPGATemperature | ( | JY5710_DeviceHandle | hDevice,
 |  | double * | temperature
 | ) |  |

Get FPGA temperature reading of the device in Celsius degree.

Parameters
hDev | device handle
temp | returned temperature value in Celsius degree
Returns
0 if success or other error code

◆ JY5710_GetDeviceID()

JY5710API int JY5710_GetDeviceID | ( | JY5710_DeviceHandle | hDevice,
 |  | int * | deviceID
 | ) |  |

Obtain the board ID.

The 5710 is a series of boards. The PXIe-5711 board ID is Ox5711 The PCIe-5711 board ID is OxA711

Parameters
hDevice | device handle
deviceID | board ID
Returns
0 if success or other error code

◆ JY5710_GetDeviceSerialNumber()

JY5710API int JY5710_GetDeviceSerialNumber | ( | JY5710_DeviceHandle | hDevice,
 |  | char * | serialNumber,
 |  | int | length
 | ) |  |

Obtain the device serialNumber

Parameters
hDevice | device handle
serialNumber | Pointer to a buffer receiving the serial number. The length of the serial number is 10.
length | serial Number length ,lenth is 10
Returns
0 if success or other error code

◆ JY5710_Open()

JY5710API int JY5710_Open | ( | int | slotNumber,
 |  | JY5710_DeviceHandle * | hDevice
 | ) |  |

Open the 5710 series boards using the slot number or the board serial number.

PXIe slot number is predefined by the PXIe chassis. PCIe slot number is defined by the DIP switch. The board serial number is defined by the system starting from 0. It's your responsibility to know the number. For a single board, the serial number is 0.

Parameters
slotNumber | slot number or board serial number
hDevice | device handle. All other functions uses hDevice to represent this device.
Returns
0 if success or other error code

◆ JY5710_OpenByName()

JY5710API int JY5710_OpenByName | ( | const char * | cardName,
 |  | JY5710_DeviceHandle * | hDevice
 | ) |  |

Open this 5710 series boards using the board alias name which is set by JYTEK utility JYDM.

You can change the name using JYDM.

Parameters
cardName | board alias name
hDevice | device handle
Returns
0 if success or other error code

◆ JY5710_SetDeviceReferenceClock()

JY5710API int JY5710_SetDeviceReferenceClock | ( | JY5710_DeviceHandle | hDevice,
 |  | JY5710_ReferenceClock | clkSource
 | ) |  |

Set ReferenceClock for the device.There are two ReferenceClock, 25MHz from this device or 100MHz from the PXIe chassis.

PCIe device only supports 25MHz timebase.

Parameters
hDevice | device handle
clkSource | ReferenceClock source defined by enum JY5710_ReferenceClock
Returns
0 if success or other error code

◆ JY5710_SetDeviceStatusLed()

JY5710API int JY5710_SetDeviceStatusLed | ( | JY5710_DeviceHandle | hDevice,
 |  | bool | enable,
 |  | unsigned int | frequency
 | ) |  |

Control Front Panel Status Led

Parameters
hDevice | device handle
enable | enable front panel status led blink, true: blink, false: not blink
frequency | when enable is ture, the led blink speed by frequency define
Returns
0 if success or other error code

◆ JY5710_SignalRouting()

JY5710API int JY5710_SignalRouting | ( | JY5710_DeviceHandle | hDevice,
 |  | JY5710_Signal_Source | source,
 |  | JY5710_Signal_Destination | destination
 | ) |  |

Route a singal from source to destination.

Both source and destination are defined by the corresponding enum JY5710_SourceSignal and JY5710_DestinationSignal. One source signal may be routed to multiple destinations.

Parameters
hDevice | device handle
source | source of the signal defined by enum JY5710_Signal_Source
destination | destination of the signal defined by enum JY5710_Signal_Destination
Returns
0 if success or other error code


5710 C++ Programming Manual: D: Directory Reference

  • D:
D: Directory Reference

Directories

directory 5710


5710 C++ Programming Manual: D:/5710 Directory Reference

  • D:
  • 5710
5710 Directory Reference

Directories

directory Cpp


5710 C++ Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 1234]
▼ D: |
▼ 5710 |
▼ Cpp |
JY5710.h | @SectionBegin JY5710 FileHead


5710 C++ Programming Manual: File Members

Here is a list of all file members with links to the files they belong to:

- j -

  • JY5710_AO_CheckBufferStatus() : JY5710.h
  • JY5710_AO_CheckBufferStatusEx() : JY5710.h
  • JY5710_AO_ContinuousNoWrapping : JY5710.h
  • JY5710_AO_ContinuousWrapping : JY5710.h
  • JY5710_AO_Digital : JY5710.h
  • JY5710_AO_EnableChannel() : JY5710.h
  • JY5710_AO_Finite : JY5710.h
  • JY5710_AO_Immediately : JY5710.h
  • JY5710_AO_SampleClock : JY5710.h
  • JY5710_AO_SendSoftTrigger() : JY5710.h
  • JY5710_AO_SetDigitalStartTrigger() : JY5710.h
  • JY5710_AO_SetMode() : JY5710.h
  • JY5710_AO_SetSampleClock() : JY5710.h
  • JY5710_AO_SetSamplesToUpdate() : JY5710.h
  • JY5710_AO_SetStartTriggerType() : JY5710.h
  • JY5710_AO_SetUpdateRate() : JY5710.h
  • JY5710_AO_Single : JY5710.h
  • JY5710_AO_Soft : JY5710.h
  • JY5710_AO_Start() : JY5710.h
  • JY5710_AO_StartTrig : JY5710.h
  • JY5710_AO_Stop() : JY5710.h
  • JY5710_AO_TriggerType : JY5710.h
  • JY5710_AO_UpdateMode : JY5710.h
  • JY5710_AO_WaitUntilDone() : JY5710.h
  • JY5710_AO_WriteData() : JY5710.h
  • JY5710_AO_WriteRawData() : JY5710.h
  • JY5710_AO_WriteRawSinglePoint() : JY5710.h
  • JY5710_AO_WriteSinglePoint() : JY5710.h
  • JY5710_ClockSource : JY5710.h
  • JY5710_Close() : JY5710.h
  • JY5710_DeviceHandle : JY5710.h
  • JY5710_DI_AddLines() : JY5710.h
  • JY5710_DI_ReadSinglePoint() : JY5710.h
  • JY5710_DI_ReadSinglePoint_U8() : JY5710.h
  • JY5710_DI_Start() : JY5710.h
  • JY5710_DI_Stop() : JY5710.h
  • JY5710_DigitalTriggerEdge : JY5710.h
  • JY5710_DigitalTriggerSource : JY5710.h
  • JY5710_DisableAOCalibration() : JY5710.h
  • JY5710_DisconnectSignalRouting() : JY5710.h
  • JY5710_DO_AddLines() : JY5710.h
  • JY5710_DO_Start() : JY5710.h
  • JY5710_DO_Stop() : JY5710.h
  • JY5710_DO_WriteSinglePoint() : JY5710.h
  • JY5710_DO_WriteSinglePoint_U8() : JY5710.h
  • JY5710_ExternalClock : JY5710.h
  • JY5710_ExternalClockTerminal : JY5710.h
  • JY5710_Falling : JY5710.h
  • JY5710_GetDeviceFPGATemperature() : JY5710.h
  • JY5710_GetDeviceID() : JY5710.h
  • JY5710_GetDeviceSerialNumber() : JY5710.h
  • JY5710_Internal : JY5710.h
  • JY5710_InternalClock : JY5710.h
  • JY5710_Open() : JY5710.h
  • JY5710_OpenByName() : JY5710.h
  • JY5710_PFI0 : JY5710.h
  • JY5710_PFI0_OUT : JY5710.h
  • JY5710_PFI1 : JY5710.h
  • JY5710_PFI1_OUT : JY5710.h
  • JY5710_PFI2 : JY5710.h
  • JY5710_PFI2_OUT : JY5710.h
  • JY5710_PFI_0_IN : JY5710.h
  • JY5710_PFI_1_IN : JY5710.h
  • JY5710_PFI_2_IN : JY5710.h
  • JY5710_PXI_Trig0 : JY5710.h
  • JY5710_PXI_Trig0_IN : JY5710.h
  • JY5710_PXI_Trig1 : JY5710.h
  • JY5710_PXI_Trig1_IN : JY5710.h
  • JY5710_PXI_Trig2 : JY5710.h
  • JY5710_PXI_Trig2_IN : JY5710.h
  • JY5710_PXI_Trig3 : JY5710.h
  • JY5710_PXI_Trig3_IN : JY5710.h
  • JY5710_PXI_Trig4 : JY5710.h
  • JY5710_PXI_Trig4_IN : JY5710.h
  • JY5710_PXI_Trig5 : JY5710.h
  • JY5710_PXI_Trig5_IN : JY5710.h
  • JY5710_PXI_Trig6 : JY5710.h
  • JY5710_PXI_Trig6_IN : JY5710.h
  • JY5710_PXI_Trig7 : JY5710.h
  • JY5710_PXI_Trig7_IN : JY5710.h
  • JY5710_PXIe_Clk100 : JY5710.h
  • JY5710_PXITrig0_OUT : JY5710.h
  • JY5710_PXITrig1_OUT : JY5710.h
  • JY5710_PXITrig2_OUT : JY5710.h
  • JY5710_PXITrig3_OUT : JY5710.h
  • JY5710_PXITrig4_OUT : JY5710.h
  • JY5710_PXITrig5_OUT : JY5710.h
  • JY5710_PXITrig6_OUT : JY5710.h
  • JY5710_PXITrig7_OUT : JY5710.h
  • JY5710_ReferenceClock : JY5710.h
  • JY5710_ReferenceTrigger : JY5710.h
  • JY5710_Rising : JY5710.h
  • JY5710_SetDeviceReferenceClock() : JY5710.h
  • JY5710_SetDeviceStatusLed() : JY5710.h
  • JY5710_Signal_Destination : JY5710.h
  • JY5710_Signal_Source : JY5710.h
  • JY5710_SignalRouting() : JY5710.h
  • JY5710_StartTrigger : JY5710.h
  • JY5710_TriggerMode : JY5710.h


5710 C++ Programming Manual: File Members

  • JY5710_AO_TriggerType : JY5710.h
  • JY5710_AO_UpdateMode : JY5710.h
  • JY5710_ClockSource : JY5710.h
  • JY5710_DigitalTriggerEdge : JY5710.h
  • JY5710_DigitalTriggerSource : JY5710.h
  • JY5710_ExternalClockTerminal : JY5710.h
  • JY5710_ReferenceClock : JY5710.h
  • JY5710_Signal_Destination : JY5710.h
  • JY5710_Signal_Source : JY5710.h
  • JY5710_TriggerMode : JY5710.h


5710 C++ Programming Manual: File Members

- j -

  • JY5710_AO_ContinuousNoWrapping : JY5710.h
  • JY5710_AO_ContinuousWrapping : JY5710.h
  • JY5710_AO_Digital : JY5710.h
  • JY5710_AO_Finite : JY5710.h
  • JY5710_AO_Immediately : JY5710.h
  • JY5710_AO_SampleClock : JY5710.h
  • JY5710_AO_Single : JY5710.h
  • JY5710_AO_Soft : JY5710.h
  • JY5710_AO_StartTrig : JY5710.h
  • JY5710_ExternalClock : JY5710.h
  • JY5710_Falling : JY5710.h
  • JY5710_Internal : JY5710.h
  • JY5710_InternalClock : JY5710.h
  • JY5710_PFI0 : JY5710.h
  • JY5710_PFI0_OUT : JY5710.h
  • JY5710_PFI1 : JY5710.h
  • JY5710_PFI1_OUT : JY5710.h
  • JY5710_PFI2 : JY5710.h
  • JY5710_PFI2_OUT : JY5710.h
  • JY5710_PFI_0_IN : JY5710.h
  • JY5710_PFI_1_IN : JY5710.h
  • JY5710_PFI_2_IN : JY5710.h
  • JY5710_PXI_Trig0 : JY5710.h
  • JY5710_PXI_Trig0_IN : JY5710.h
  • JY5710_PXI_Trig1 : JY5710.h
  • JY5710_PXI_Trig1_IN : JY5710.h
  • JY5710_PXI_Trig2 : JY5710.h
  • JY5710_PXI_Trig2_IN : JY5710.h
  • JY5710_PXI_Trig3 : JY5710.h
  • JY5710_PXI_Trig3_IN : JY5710.h
  • JY5710_PXI_Trig4 : JY5710.h
  • JY5710_PXI_Trig4_IN : JY5710.h
  • JY5710_PXI_Trig5 : JY5710.h
  • JY5710_PXI_Trig5_IN : JY5710.h
  • JY5710_PXI_Trig6 : JY5710.h
  • JY5710_PXI_Trig6_IN : JY5710.h
  • JY5710_PXI_Trig7 : JY5710.h
  • JY5710_PXI_Trig7_IN : JY5710.h
  • JY5710_PXIe_Clk100 : JY5710.h
  • JY5710_PXITrig0_OUT : JY5710.h
  • JY5710_PXITrig1_OUT : JY5710.h
  • JY5710_PXITrig2_OUT : JY5710.h
  • JY5710_PXITrig3_OUT : JY5710.h
  • JY5710_PXITrig4_OUT : JY5710.h
  • JY5710_PXITrig5_OUT : JY5710.h
  • JY5710_PXITrig6_OUT : JY5710.h
  • JY5710_PXITrig7_OUT : JY5710.h
  • JY5710_ReferenceTrigger : JY5710.h
  • JY5710_Rising : JY5710.h
  • JY5710_StartTrigger : JY5710.h


5710 C++ Programming Manual: File Members

- j -

  • JY5710_AO_CheckBufferStatus() : JY5710.h
  • JY5710_AO_CheckBufferStatusEx() : JY5710.h
  • JY5710_AO_EnableChannel() : JY5710.h
  • JY5710_AO_SendSoftTrigger() : JY5710.h
  • JY5710_AO_SetDigitalStartTrigger() : JY5710.h
  • JY5710_AO_SetMode() : JY5710.h
  • JY5710_AO_SetSampleClock() : JY5710.h
  • JY5710_AO_SetSamplesToUpdate() : JY5710.h
  • JY5710_AO_SetStartTriggerType() : JY5710.h
  • JY5710_AO_SetUpdateRate() : JY5710.h
  • JY5710_AO_Start() : JY5710.h
  • JY5710_AO_Stop() : JY5710.h
  • JY5710_AO_WaitUntilDone() : JY5710.h
  • JY5710_AO_WriteData() : JY5710.h
  • JY5710_AO_WriteRawData() : JY5710.h
  • JY5710_AO_WriteRawSinglePoint() : JY5710.h
  • JY5710_AO_WriteSinglePoint() : JY5710.h
  • JY5710_Close() : JY5710.h
  • JY5710_DI_AddLines() : JY5710.h
  • JY5710_DI_ReadSinglePoint() : JY5710.h
  • JY5710_DI_ReadSinglePoint_U8() : JY5710.h
  • JY5710_DI_Start() : JY5710.h
  • JY5710_DI_Stop() : JY5710.h
  • JY5710_DisableAOCalibration() : JY5710.h
  • JY5710_DisconnectSignalRouting() : JY5710.h
  • JY5710_DO_AddLines() : JY5710.h
  • JY5710_DO_Start() : JY5710.h
  • JY5710_DO_Stop() : JY5710.h
  • JY5710_DO_WriteSinglePoint() : JY5710.h
  • JY5710_DO_WriteSinglePoint_U8() : JY5710.h
  • JY5710_GetDeviceFPGATemperature() : JY5710.h
  • JY5710_GetDeviceID() : JY5710.h
  • JY5710_GetDeviceSerialNumber() : JY5710.h
  • JY5710_Open() : JY5710.h
  • JY5710_OpenByName() : JY5710.h
  • JY5710_SetDeviceReferenceClock() : JY5710.h
  • JY5710_SetDeviceStatusLed() : JY5710.h
  • JY5710_SignalRouting() : JY5710.h


5710 C++ Programming Manual: File Members

  • JY5710_DeviceHandle : JY5710.h


5710 C++ Programming Manual: Main Page

5710 C++ Programming Manual Documentation